Social Icons

Wednesday, April 23, 2014

CCNP ROUTE: LAB Setup for BGP


The above diagram will be used for studying all BGP concepts in the CCNP ROUTE 642-902 curriculum, plus CCIE topics like Route Reflectors and Confederations.
Graphical Network Simulator (GNS3 0.8.3) has been used to build this topology. All routers are Cisco 2691 series, running the c2691-adventerprisek9-mz.124-25c image.

You can download this entire GNS3 CCNP lab (including the topology and configuration files for all routers) from HERE.

All 13 routers in the topology are configured with IP addresses.

All lab exercises will be based on these configurations, with a general reloading process after each excercise, so the settings made in one lab will not interact with those made in the next one. After each router reloading, all IP addresses and basic routing protocol settings will be automatically restored from the configuration files saved in the CCNP_ROUTE_BGP_lab folder.

Note 1: Do not forget to recalculate the IdlePC value for the routers once you start this lab in GNS3!

Note 2: Do not forget to edit the topology file (using a text editor) and modify the IOS path or other parameters according to your operating system and file locations!

Note 3: This topology and its related configuration can be improved in many ways, but since it is 100% functional and all the theoretical concepts are applied within the exercises with the expected results, it may be considered a good practice for the CCNP ROUTE exam.

Note 4: R105, R106 and R107 will be configured later on.

Note 5: For any GNS3 errors when opening/using the topology please refer to http://forum.gns3.net/.

Note 6: If you see the below error when loading the GNS3 topology, check the project's "config" folder to see if the router config files have the .cfg extension, and not .cfg.txt or any other extension.
Local configuration configs\Rx.cfg cannot be found for router Rx, use default base config instead.

Most of the theory in the following labs comes from CCNP ROUTE 642-902 Official Certification Guide, Wendell Odom, Cisco Press, which is a great source of information for the ROUTE exam.

The initial configurations of the routers (these configs will be maintained after each reload):

R1#show run
!
interface FastEthernet0/0
 ip address 202.2.2.1 255.255.255.252
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.1.0.14 255.255.255.252
 clock rate 2000000
!
interface FastEthernet0/1
 ip address 201.1.1.1 255.255.255.252
 duplex auto
 speed auto
!
interface Serial0/1
 ip address 10.1.0.29 255.255.255.252
 clock rate 2000000
!
interface Serial0/2
 ip address 10.1.0.25 255.255.255.252
 clock rate 2000000
!
interface Serial0/3
 no ip address
 shutdown
 clock rate 2000000
!
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 network 10.1.0.0 0.0.0.255 area 0
!

R2#show run
!
interface FastEthernet0/0
 ip address 201.1.1.5 255.255.255.252
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.1.0.18 255.255.255.252
 clock rate 2000000
!
interface FastEthernet0/1
 ip address 202.2.2.5 255.255.255.252
 duplex auto
 speed auto
!
interface Serial0/1
 ip address 10.1.0.30 255.255.255.252
 clock rate 2000000
!
interface Serial0/2
 ip address 10.1.0.22 255.255.255.252
 clock rate 2000000
!
interface Serial0/3
 no ip address
 shutdown
 clock rate 2000000
!
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 network 10.1.0.0 0.0.0.255 area 0
!

R3#show run
!
interface FastEthernet0/0
 ip address 10.1.0.2 255.255.255.252
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.1.0.21 255.255.255.252
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/2
 ip address 10.1.0.13 255.255.255.252
 clock rate 2000000
!
interface Serial0/3
 ip address 10.1.0.9 255.255.255.252
 clock rate 2000000
!
router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 network 10.1.0.0 0.0.0.255 area 0
!

R4#show run
!
interface FastEthernet0/0
 ip address 10.1.0.6 255.255.255.252
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 10.1.0.26 255.255.255.252
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/2
 ip address 10.1.0.17 255.255.255.252
 clock rate 2000000
!
interface Serial0/3
 ip address 10.1.0.10 255.255.255.252
 clock rate 2000000
!
router ospf 1
 router-id 4.4.4.4
 log-adjacency-changes
 network 10.1.0.0 0.0.0.255 area 0
!

R5#show run
!
interface Loopback10
 ip address 172.16.10.10 255.255.255.255
!
interface Loopback11
 ip address 172.16.11.11 255.255.255.255
!
interface Loopback12
 ip address 172.16.12.12 255.255.255.255
!
interface Loopback13
 ip address 172.16.13.13 255.255.255.255
!
interface Loopback14
 ip address 172.16.14.14 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.1.0.1 255.255.255.252
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 shutdown
 clock rate 2000000
!
interface FastEthernet0/1
 ip address 10.1.0.5 255.255.255.252
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
router ospf 1
 router-id 5.5.5.5
 log-adjacency-changes
 network 10.1.0.0 0.0.0.255 area 0
!

R101#show run
!
interface FastEthernet0/0
 ip address 201.1.1.2 255.255.255.252
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 114.1.1.1 255.255.255.252
 clock rate 2000000
!
interface FastEthernet0/1
 ip address 201.1.1.6 255.255.255.252
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/2
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/3
 no ip address
 shutdown
 clock rate 2000000
!

R102#show run
!
interface FastEthernet0/0
 ip address 202.2.2.2 255.255.255.252
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 123.1.1.1 255.255.255.252
 clock rate 2000000
!
interface FastEthernet0/1
 ip address 202.2.2.6 255.255.255.252
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!

R103#show run
!
interface FastEthernet0/0
 ip address 136.1.1.1 255.255.255.252
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 123.1.1.2 255.255.255.252
 clock rate 2000000
!
interface FastEthernet0/1
 ip address 135.1.1.1 255.255.255.252
 duplex auto
 speed auto
!
interface Serial0/1
 no ip address
 shutdown
 clock rate 2000000
!
interface Serial0/2
 ip address 134.1.1.1 255.255.255.252
 clock rate 2000000
!
interface Serial0/3
 no ip address
 shutdown
 clock rate 2000000
!

R104#show run
!
interface Loopback40
 ip address 192.168.40.40 255.255.255.255
!
interface Loopback41
 ip address 192.168.41.41 255.255.255.255
!
interface Loopback42
 ip address 192.168.42.42 255.255.255.255
!
interface Loopback43
 ip address 192.168.43.43 255.255.255.255
!
interface Loopback44
 ip address 192.168.44.44 255.255.255.255
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!        
interface Serial0/0
 ip address 134.1.1.2 255.255.255.252
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 ip address 114.1.1.2 255.255.255.252
 clock rate 2000000
!

No comments:

Post a Comment