Social Icons

Saturday, July 27, 2013

CCNP ROUTE: Lab setup for EIGRP, OSPF, Path control


     The above diagram will be used for studying all EIGRP, OSPF and Path control concepts in the CCNP ROUTE 642-902 curriculum.
     This topology includes multi-area OSPF with Area 0 as the HQ backbone for the enterprise network and other OSPF areas or RIP/EIGRP domains acting like remote branches, partners or newly added companies.
     Graphical Network Simulator (GNS3 0.8.3) has been used to build this topology. All routers are Cisco 2691 series, running the c2691-adventerprisek9-mz.124-25c image.
     You can download this entire GNS3 CCNP lab (including the topology and configuration files for all routers) from HERE.
     All 13 routers in the topology are configured with IP addresses and are running routing protocols specific to their position in the diagram. All lab exercises will be based on these configurations, with a general reloading process after each excercise, so the settings made in one lab will not interact with those made in the next one. After each router reloading, all IP addresses and basic routing protocol settings will be automatically restored from the configuration files saved in the CCNP_ROUTE_lab folder. The Frame Relay switch is configured with the correct DLCI/port mappings so R9 can communicate with R10 and R11 if other problems do not exist in the topology. The Ethernet switches are using default VLAN 1.

Note 1: Loopback interfaces are by default advertised with a /32 mask. You can advertise them as usual networks by configuring each interface as a point-to-point link.

Note 2: The direct link between R4 and R5 belongs to the EIGRP domain.

Note 3: Do not forget to recalculate the IdlePC value for the routers once you start this lab in GNS3!

Note 4: Do not forget to edit the topology file (using a text editor) and modify the IOS path or other parameters according to your operating system and file locations!

Note 5: This topology and its related configuration can be improved in many ways, but since it is 100% functional and all the theoretical concepts are applied within the exercises with the expected results, it may be considered a good practice for the CCNP ROUTE exam.

Note 6: For any GNS3 errors when opening/using the topology please refer to http://forum.gns3.net/.

Note 7: If you see the below error when loading the GNS3 topology, check the project's "config" folder to see if the router config files have the .cfg extension, and not .cfg.txt or any other extension.
Local configuration configs\Rx.cfg cannot be found for router Rx, use default base config instead.

Most of the theory in the following labs comes from CCNP ROUTE 642-902 Official Certification Guide, Wendell Odom, Cisco Press, which is a great source of information for the ROUTE exam.

The initial configurations of the routers (these configs will be maintained after each reload):

1. Configuring OSPF on R1:
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 network 192.168.0.0 0.0.0.7 area 0
 network 192.168.0.12 0.0.0.3 area 0
 network 192.168.0.16 0.0.0.3 area 0
 network 192.168.0.20 0.0.0.3 area 0
 network 192.168.100.0 0.0.0.255 area 0

2. Configuring OSPF on R2:
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 area 1 stub
 network 192.168.0.0 0.0.0.7 area 0
 network 192.168.168.0 0.0.0.3 area 1

3. Configuring OSPF on R3:
router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 network 192.168.0.0 0.0.0.7 area 0
 network 192.168.13.0 0.0.0.255 area 0

4. Configuring OSPF/EIGRP on R4:
router ospf 1
 router-id 4.4.4.4
 log-adjacency-changes
 network 192.168.0.12 0.0.0.3 area 0
router eigrp 1
 network 172.16.0.2 0.0.0.0
 network 172.16.0.12 0.0.0.3
 network 192.168.44.0
 no auto-summary

5. Configuring OSPF/EIGRP on R5:
router ospf 1
 router-id 5.5.5.5
 log-adjacency-changes
 network 192.168.0.16 0.0.0.3 area 0
router eigrp 1
 network 172.16.0.6 0.0.0.0
 network 172.16.0.12 0.0.0.3
 network 192.168.55.0
 no auto-summary

6. Configuring EIGRP on R6:
router eigrp 1
 passive-interface Loopback111 (does NOT SEND or RECEIVE Hello messages on that interface)
 network 172.16.0.0
 no auto-summary

7. Configuring EIGRP/RIP on R7:
router eigrp 1
 network 172.16.0.10 0.0.0.0
 no auto-summary
router rip
 version 2
 network 10.0.0.0

8. Configuring RIP on R8:
router rip
 version 2
 passive-interface Loopback200 (accepts RIP updates, but does NOT send RIP updates on that int)
 network 10.0.0.0
 no auto-summary

9. Configuring OSPF multiarea, Frame Relay maps & OSPF over Frame Relay point-to-multipoint non-broadcast on R9, R10, R11:

R9#show run | s interface Serial0/1.1
interface Serial0/1.1 multipoint
 ip address 10.0.1.1 255.255.255.248
 ip ospf network point-to-multipoint non-broadcast
 frame-relay map ip 10.0.1.2 102
 frame-relay map ip 10.0.1.3 103
R9#show run | s ospf              
 ip ospf network point-to-multipoint non-broadcast
router ospf 1
 router-id 9.9.9.9
 log-adjacency-changes
 area 3 nssa
 network 10.0.1.0 0.0.0.255 area 2
 network 192.168.0.20 0.0.0.3 area 0
 network 192.168.3.0 0.0.0.3 area 3
 neighbor 10.0.1.3
 neighbor 10.0.1.2

R10#show run | s interface Serial0/0.1
interface Serial0/0.1 multipoint
 ip address 10.0.1.2 255.255.255.248
 ip ospf network point-to-multipoint non-broadcast
 frame-relay map ip 10.0.1.1 201
 frame-relay map ip 10.0.1.3 201
R10#show run | s ospf              
 ip ospf network point-to-multipoint non-broadcast
router ospf 1
 router-id 10.10.10.10
 log-adjacency-changes
 network 10.0.1.0 0.0.0.255 area 2
 network 10.0.10.0 0.0.0.255 area 2
 neighbor 10.0.1.1

R11#show run | s interface Serial0/0.1
interface Serial0/0.1 multipoint
 ip address 10.0.1.3 255.255.255.248
 ip ospf network point-to-multipoint non-broadcast
 frame-relay map ip 10.0.1.1 301
 frame-relay map ip 10.0.1.2 301
R11#show run | s ospf              
 ip ospf network point-to-multipoint non-broadcast
router ospf 1
 router-id 11.11.11.11
 log-adjacency-changes
 network 10.0.1.0 0.0.0.255 area 2
 network 10.0.11.0 0.0.0.255 area 2
 neighbor 10.0.1.1

10. Configuring OSPF/RIP on R12:
router ospf 1
 router-id 12.12.12.12
 log-adjacency-changes
 area 3 nssa
 network 192.168.3.0 0.0.0.3 area 3
 network 192.168.33.0 0.0.0.255 area 3
router rip
 version 2
 passive-interface Loopback22
 passive-interface Loopback33
 network 192.168.22.0
 no auto-summary

11. Configuring OSPF on R13:
router ospf 1
 router-id 13.13.13.13
 log-adjacency-changes
 area 1 stub
 network 192.168.168.0 0.0.0.3 area 1
 network 192.168.169.0 0.0.0.255 area 1

No comments:

Post a Comment