Social Icons

Sunday, April 13, 2014

CCNP ROUTE: 5. Issues with multiple redistribution points

To avoid having a single point of failure, most redistribution designs call for a minimum of two routers performing redistribution.
Domain loops (page 344 in the CCNP ROUTE book) do not occur, at least with default settings, when EIGRP is one of the two routing protocols.

A. Preventing Routing Domain Loops with Higher Metrics

One easy method of preventing the domain loop problem is to assign purposefully high metric values when redistributing routes.
Since we don't have double redistribution points between OSPF and RIP in our GNS3 network, please refer to the figure and comments on page 345 of the book.

Note: OSPF actually defeats the domain loop problem without using the higher metrics.
OSPF always prefers internal routes over E1 routes, and E1 routes over E2 routes, before even considering the metrics.

B. Preventing Routing Domain Loops with Administrative Distance

Each router associates an administrative distance (AD) with every route it considers to be added to the routing table.
When a router must consider multiple routes from different sources for the exact same prefix/length, the first item considered by the router is not the metric, but rather the AD. The lower the AD, the better the route.

Default ADs: Connected 0, Static 1, EIGRP summary 5, EIGRP internal 90, OSPF 110, RIP 120, EIGRP external 170.

B1. EIGRP Default AD Defeats Loop from EIGRP to OSPF to EIGRP

The default AD settings for EIGRP takes care of the domain loop problem when redistributing between EIGRP and OSPF.
Let's consider the 172.16.0.8/30 subnet and double mutual redistribution between EIGRP and OSPF through R4 and R5.
Disable the link between R4 and R5!

R4(config)#router eigrp 1
R4(config-router)#redistribute ospf 1 metric 1500 100 255 1 1500
R4(config-router)#ex
R4(config)#router ospf 1
R4(config-router)#redistribute eigrp 1 subnets
R4(config-router)#ex

R5(config)#router eigrp 1
R5(config-router)#redistribute ospf 1 metric 1500 100 255 1 1500
R5(config-router)#ex
R5(config)#router ospf 1
R5(config-router)#redistribute eigrp 1 subnets
R5(config-router)#ex

Router R5 hears about a route for subnet 172.16.0.8/30 as an internal EIGRP route (default AD 90) on the left.
R5 also hears about the subnet as an external OSPF route on the right (default AD 110).
As a result, R5 will do a couple of things that are important to this discussion:
- R5 considers the internal EIGRP route as the best route, because of the lower AD (90 < 110), and places that route in its own IP routing table.
- R5 does not redistribute a route for subnet 172.16.0.8/30, from OSPF back to EIGRP, because R5 does not have an OSPF route for subnet 172.16.0.8/30.
  A route must be in the routing table before it can be redistributed.

R5#show ip route 172.16.0.8  
Routing entry for 172.16.0.8/30
  Known via "eigrp 1", distance 90, metric 2195456, type internal
  Redistributing via eigrp 1, ospf 1
  Advertised by ospf 1 subnets
  Last update from 172.16.0.5 on FastEthernet0/0, 00:29:36 ago
  Routing Descriptor Blocks:
  * 172.16.0.5, from 172.16.0.5, 00:29:36 ago, via FastEthernet0/0
      Route metric is 2195456, traffic share count is 1
      Total delay is 21000 microseconds, minimum bandwidth is 1544 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 1

B2. EIGRP Default AD Defeats Loop from OSPF to EIGRP to OSPF

Using the same configurations as above, let's consider the reverse situation and focus on the 192.168.0.20/30 subnet on R5.

Router R5 hears about a route for subnet 192.168.0.20/30 as an external EIGRP route (default AD 170) and an internal OSPF route (default AD 110).
As a result, R5 chooses the OSPF internal route as the best route and adds that to R5’s routing table.
Because R5 does not have an EIGRP route for subnet 192.168.0.20/30, R5 will not redistribute a route for subnet 192.168.0.20/30 from EIGRP into OSPF, again defeating the domain loop problem.

R5#show ip route 192.168.0.20        
Routing entry for 192.168.0.20/30
  Known via "ospf 1", distance 110, metric 128, type intra area
  Redistributing via eigrp 1
  Advertised by eigrp 1 metric 1500 100 255 1 1500
  Last update from 192.168.0.17 on Serial0/0, 00:13:08 ago
  Routing Descriptor Blocks:
  * 192.168.0.17, from 1.1.1.1, 00:13:08 ago, via Serial0/0
      Route metric is 128, traffic share count is 1

The reason that the default EIGRP AD settings work well can be summarized generically as follows:

For each of the two routing protocols, the AD used for internal routes for one routing protocol is better than the AD used for external routes by the other routing protocol.
When comparing EIGRP’s and OSPF’s defaults, both of the generic criteria are met:
- EIGRP internal AD 90 < OSPF external AD 110
- OSPF internal AD 110 < EIGRP external AD 170
Likewise, when redistributing between EIGRP and RIP:
- EIGRP internal AD 90 < RIP external AD 120
- RIP internal AD 120 < EIGRP external AD 170

When redistributing between OSPF and RIP, the default AD settings do not defeat the domain loop problem.
Setting AD Values with the distance Command:

RIP - distance ad-value
EIGRP - distance eigrp internal-ad external-ad
OSPF - distance ospf {external ad-value} {intra-area ad-value} {inter-area ad-value}

To defeat the OSPF-RIP domain loop problem by setting AD, just configure the AD for OSPF external routes using the distance ospf external ad-value command in OSPF configuration mode.
The value should be higher than RIP’s AD on that same router (value > 120 for the default RIP AD).

C. Domain Loop Problems with More than Two Routing Domains

Using the same configurations as above, let's add the RIP domain next to the EIGRP domain in discussion.
R7 will redistribute RIP routes to the EIGRP domain. Let's focus on what R6 receives regarding those routes from RIP (10.0.200.0/24 for example).

R7(config)#router eigrp 1
R7(config-router)#redistribute rip metric 1500 100 255 1 1500

R6#show ip route 10.0.200.0  
Routing entry for 10.0.200.0/24
  Known via "eigrp 1", distance 170, metric 1757696, type external
  Redistributing via eigrp 1
  Last update from 172.16.0.6 on FastEthernet0/1, 00:04:01 ago
  Routing Descriptor Blocks:
  * 172.16.0.6, from 172.16.0.6, 00:04:01 ago, via FastEthernet0/1
      Route metric is 1757696, traffic share count is 1
      Total delay is 2000 microseconds, minimum bandwidth is 1500 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 1

As we can see, R6 learned the route to the RIP subnet via 172.16.0.6, meaning R5, and not R7 as expected.
A traceroute to the destination shows the domain routing loop which has occured (R6-R5-R1-R4-R6):

R6#traceroute 10.0.200.0

Type escape sequence to abort.
Tracing the route to 10.0.200.0

  1 172.16.0.6 36 msec 60 msec 8 msec
  2 192.168.0.17 32 msec 44 msec 0 msec
  3 192.168.0.14 36 msec 28 msec 4 msec
  4 172.16.0.1 32 msec 12 msec 12 msec
  5 172.16.0.6 52 msec 24 msec 84 msec
  6 192.168.0.17 32 msec 28 msec 40 msec
  7 192.168.0.14 52 msec 28 msec 36 msec
  8 172.16.0.1 44 msec 52 msec 44 msec
  9 172.16.0.6 52 msec 64 msec 60 msec
 10 192.168.0.17 68 msec 64 msec 60 msec
 11 192.168.0.14 104 msec 72 msec 56 msec
 12 172.16.0.1 60 msec 56 msec 64 msec
 13 172.16.0.6 68 msec 96 msec 84 msec
 14 192.168.0.17 96 msec 84 msec 76 msec
 15 192.168.0.14 76 msec 84 msec 80 msec
 16 172.16.0.1 92 msec 100 msec 84 msec
 17 172.16.0.6 100 msec 116 msec 104 msec
 18 192.168.0.17 92 msec 108 msec 76 msec
 19 192.168.0.14 156 msec 96 msec 92 msec
 20 172.16.0.1 116 msec 112 msec 104 msec
 21 172.16.0.6 124 msec 152 msec 112 msec
 22 192.168.0.17 104 msec 124 msec 96 msec
 23 192.168.0.14 92 msec 104 msec 88 msec
 24 172.16.0.1 96 msec 72 msec 144 msec
 25 172.16.0.6 124 msec 100 msec 100 msec
 26 192.168.0.17 140 msec 124 msec 132 msec
 27 192.168.0.14 100 msec 152 msec 120 msec
 28 172.16.0.1 104 msec 104 msec 116 msec
 29 172.16.0.6 140 msec 128 msec 140 msec
 30 192.168.0.17 160 msec 184 msec 144 msec

The following steps explain the problem:

Step 1. Router R7 advertises a route for network 10.0.200.0/24 from the RIP domain into the EIGRP domain where the route is treated with (default) AD 170 as an external route.
Step 2. Router R4 redistributes this EIGRP external route into OSPF where it is treated as an E2 route, AD 110, by default.
Step 3. Router R5 uses the AD 110 E2 route, rather than the AD 170 EIGRP external route, as its best route for 10.0.200.0/24.
As a result, R5 can then redistribute that OSPF route back into EIGRP as an external route.
Step 4. Router R6 learns of two external routes for 172.20.0.0/16, and the routes tie based on AD (170).
R6 may have a better EIGRP metric through R5, depending on the metrics used at redistribution, preferring this long route through the OSPF domain as shown.

R6#show ip eigrp topology 10.0.200.0/24
IP-EIGRP (AS 1): Topology entry for 10.0.200.0/24
  State is Passive, Query origin flag is 1, 1 Successor(s), FD is 1757696
  Routing Descriptor Blocks:
  172.16.0.6 (FastEthernet0/1), from 172.16.0.6, Send flag is 0x0
      Composite metric is (1757696/1732096), Route is External
      Vector metric:
        Minimum bandwidth is 1500 Kbit
        Total delay is 2000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1
      External data:
        Originating router is 192.168.55.55
        AS number of route is 1
        External protocol is OSPF, external metric is 20
        Administrator tag is 0 (0x00000000)
  172.16.0.10 (Serial0/1), from 172.16.0.10, Send flag is 0x0
      Composite metric is (2244096/1732096), Route is External
      Vector metric:
        Minimum bandwidth is 1500 Kbit
        Total delay is 21000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1
      External data:
        Originating router is 172.16.0.10
        AS number of route is 0
        External protocol is RIP, external metric is 1
        Administrator tag is 0 (0x00000000)

As described in Step 3, R5 chooses the O E2 route instead of D EX (110 < 170) and redistributes this route back to EIGRP (R6 is pointing to R5 for reaching the destination RIP subnet):

R6#show ip route
...
D EX    10.0.200.0/24 [170/1757696] via 172.16.0.6, 00:25:34, FastEthernet0/1

R5#show ip route
...
O E2    10.0.200.0/24 [110/20] via 192.168.0.17, 00:26:14, Serial0/0

R5#show ip route 10.0.200.0
Routing entry for 10.0.200.0/24
  Known via "ospf 1", distance 110, metric 20, type extern 2, forward metric 128
  Redistributing via eigrp 1
  Advertised by eigrp 1 metric 1500 100 255 1 1500
  Last update from 192.168.0.17 on Serial0/0, 00:38:47 ago
  Routing Descriptor Blocks:
  * 192.168.0.17, from 4.4.4.4, 00:38:47 ago, via Serial0/0
      Route metric is 20, traffic share count is 1

The next three sections address solutions to this problem, namely:
- using per-route AD settings,
- filtering routes based on prefix/length
- using route tags

C1. Using Per-route Administrative Distance Settings

We can use the distance router subcommand to set the AD value on R5 per routing protocol, per type (internal and external).

Syntax:
distance distance ip-adv-router wc-mask [acl-number-or-name]

R5(config)#ip access-list standard match200
R5(config-std-nacl)#permit host 10.0.200.0
R5(config-std-nacl)#exit
R5(config)#router ospf 1
R5(config-router)#distance 171 4.4.4.4 0.0.0.0 match200

R4(config)#ip access-list standard match200
R4(config-std-nacl)#permit host 10.0.200.0
R4(config-std-nacl)#exit
R4(config)#router ospf 1
R4(config-router)#distance 171 5.5.5.5 0.0.0.0 match200

Note: A complete solution requires all redistributing routers to perform this kind of configuration.
Note: When used as a RIP or EIGRP subcommand, the distance command matches the interface IP address of the neighboring router that advertises the route, and not the RID.

R4#show ip route 10.0.200.0
Routing entry for 10.0.200.0/24
  Known via "eigrp 1", distance 170, metric 2756096, type external
  Redistributing via eigrp 1, ospf 1
  Advertised by ospf 1 subnets
  Last update from 172.16.0.1 on Serial0/0, 00:01:19 ago
  Routing Descriptor Blocks:
  * 172.16.0.1, from 172.16.0.1, 00:01:19 ago, via Serial0/0
      Route metric is 2756096, traffic share count is 1
      Total delay is 41000 microseconds, minimum bandwidth is 1500 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 2

R5#show ip route 10.0.200.0
Routing entry for 10.0.200.0/24
  Known via "eigrp 1", distance 170, metric 2269696, type external
  Redistributing via eigrp 1, ospf 1
  Advertised by ospf 1 subnets
  Last update from 172.16.0.5 on FastEthernet0/0, 00:01:02 ago
  Routing Descriptor Blocks:
  * 172.16.0.5, from 172.16.0.5, 00:01:02 ago, via FastEthernet0/0
      Route metric is 2269696, traffic share count is 1
      Total delay is 22000 microseconds, minimum bandwidth is 1500 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 2

Because R5 no longer has an OSPF route for 10.0.200.0/24, R5 will not redistribute such an OSPF route back into EIGRP, defeating the domain loop problem.

Now the traceroute correctly points to R7 as the next-hop:
R6#traceroute 10.0.200.0

Type escape sequence to abort.
Tracing the route to 10.0.200.0

  1 172.16.0.10 44 msec 8 msec 0 msec
  2  *  *  *
  ...

C2. Preventing Domain Loops by Filtering on Subnet While Redistributing (filtering the routes based on prefix)

This solution considers the following steps:

Step 1. Router R7 advertises a route for network 10.0.200.0/24 from the RIP domain into the EIGRP domain.
Step 2. Routers R4 and R5 both redistribute this EIGRP external route into OSPF.
Step 3. Both R4 and R5 flood the route advertisement for the OSPF external route throughout the OSPF domain.
Step 4. Both R4 and R5 apply a route-map to their redistribution from OSPF into EIGRP, filtering routes with prefix 10.0.200.0.

Let's consider the same redistribution configuration as above (except the ACL and distance settings).

R4(config)#router eigrp 1
R4(config-router)#redistribute ospf 1 metric 1500 100 255 1 1500
R4(config-router)#router ospf 1
R4(config-router)#redistribute eigrp 1 subnets

R5(config)#router eigrp 1
R5(config-router)#redistribute ospf 1 metric 1500 100 255 1 1500
R5(config-router)#router ospf 1
R5(config-router)#redistribute eigrp 1 subnets

R7(config)#router eigrp 1
R7(config-router)#redistribute rip metric 1500 100 255 1 1500

R6#show ip eigrp topology 10.0.200.0/24
IP-EIGRP (AS 1): Topology entry for 10.0.200.0/24
  State is Passive, Query origin flag is 1, 2 Successor(s), FD is 1757696
  Routing Descriptor Blocks:
  172.16.0.2 (Serial0/0), from 172.16.0.2, Send flag is 0x0
      Composite metric is (2244096/1732096), Route is External
      Vector metric:
        Minimum bandwidth is 1500 Kbit
        Total delay is 21000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1
      External data:
        Originating router is 192.168.44.44
        AS number of route is 1
        External protocol is OSPF, external metric is 20
        Administrator tag is 0 (0x00000000)
  172.16.0.10 (Serial0/1), from 172.16.0.10, Send flag is 0x0
      Composite metric is (2244096/1732096), Route is External
      Vector metric:
        Minimum bandwidth is 1500 Kbit
        Total delay is 21000 microseconds
        Reliability is 255/255
        Load is 1/255
        Minimum MTU is 1500
        Hop count is 1
      External data:
        Originating router is 172.16.0.10
        AS number of route is 0
        External protocol is RIP, external metric is 1
        Administrator tag is 0 (0x00000000)

R6#show ip route 10.0.200.0
Routing entry for 10.0.200.0/24
  Known via "eigrp 1", distance 170, metric 2244096, type external
  Redistributing via eigrp 1
  Last update from 172.16.0.10 on Serial0/1, 00:04:49 ago
  Routing Descriptor Blocks:
  * 172.16.0.10, from 172.16.0.10, 00:04:49 ago, via Serial0/1
      Route metric is 2244096, traffic share count is 1
      Total delay is 21000 microseconds, minimum bandwidth is 1500 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 1
    172.16.0.2, from 172.16.0.2, 00:04:49 ago, via Serial0/0
      Route metric is 2244096, traffic share count is 1
      Total delay is 21000 microseconds, minimum bandwidth is 1500 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 1

R6 again has two next hop IP addresses for reaching the RIP subnet 10.0.200.0/24.
The path R6 should choose is only through 172.16.0.10 (R7), and not 172.16.0.2 (R4).
To avoid this issue, we can apply route maps to both border routers to make them stop advertising the 10.0.200.0/24 route from OSPF back to EIGRP.

R4(config)#ip prefix-list match200 permit 10.0.200.0/24
R4(config)#route-map match200 deny 10
R4(config-route-map)#match ip address prefix-list match200
R4(config-route-map)#route-map match200 permit 20

R5(config)#ip prefix-list match200 permit 10.0.200.0/24
R5(config)#route-map match200 deny 10
R5(config-route-map)#match ip address prefix-list match200
R5(config-route-map)#route-map match200 permit 20

R4(config)#router eigrp 1
R4(config-router)#no redistribute ospf 1 metric 1500 100 255 1 1500
R4(config-router)#redistribute ospf 1 metric 1500 100 255 1 1500 route-map match200

R5(config)#router eigrp 1
R5(config-router)#no redistribute ospf 1 metric 1500 100 255 1 1500
R5(config-router)#redistribute ospf 1 metric 1500 100 255 1 1500 route-map match200

Now, R6 has a single and correct next hop address for subnet 10.0.200.0/24 - R7:
R6#show ip route 10.0.200.0
Routing entry for 10.0.200.0/24
  Known via "eigrp 1", distance 170, metric 2244096, type external
  Redistributing via eigrp 1
  Last update from 172.16.0.10 on Serial0/1, 00:02:23 ago
  Routing Descriptor Blocks:
  * 172.16.0.10, from 172.16.0.10, 00:02:23 ago, via Serial0/1
      Route metric is 2244096, traffic share count is 1
      Total delay is 21000 microseconds, minimum bandwidth is 1500 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 1

R6#traceroute 10.0.200.0

Type escape sequence to abort.
Tracing the route to 10.0.200.0

  1 172.16.0.10 28 msec 16 msec 20 msec
  2  *  *  *
  ...

C3. Preventing Domain Loops by Filtering on route-tag Using Distribute Lists

A route tag is a unitless 32-bit integer that most routing protocols can assign to any given route.
The assignment of a tag occurs when some IOS function adds the tag–for instance, it can be assigned by a route-map referenced by a routing protocol distribute-list or redistribute command.
That tag follows the route advertisement, even through the redistribution process.
At some later point in the flooding of routing information, other IOS tools, typically other route-maps, can match routes with a given route tag to make a decision.

To use route tags to prevent domain loop problems, you can use the following strategy:
- Choose and set a tag value that identifies routes taken from domain X and advertised into domain Y.
- When redistributing in the opposite direction (from domain Y into domain X), match the tag value and filter routes with that tag.

Let's consider the double mutual redistribution between EIGRP and OSPF through R4 and R5 and the RIP to EIGRP redistribution of 10.0.200.0, which creates a domain loop, as seen above.
We will create route tag 55 to mean “routes taken from EIGRP and redistributed into OSPF.”

Starting without any redistribution configuration:

R7(config)#router eigrp 1
R7(config-router)#redistribute rip metric 1500 100 255 1 1500

The route to 10.0.200.0/24 reached R4:

R4#show ip route | i 10.0.200.0
D EX    10.0.200.0/24 [170/2756096] via 172.16.0.1, 00:00:47, Serial0/0

R4(config)#router ospf 1
R4(config-router)#redistribute eigrp 1 subnets
R4(config)#router eigrp 1
R4(config-router)#redistribute ospf 1 metric 1500 100 255 1 1500

R5(config)#router eigrp 1
R5(config-router)#redistribute ospf 1 metric 1500 100 255 1 1500
R5(config-router)#router ospf 1
R5(config-router)#redistribute eigrp 1 subnets

R5 chooses the path through R1 due to the lower AD of OSPF compared to external EIGRP.
R5#show ip route | i 10.0.200.0
O E2    10.0.200.0/24 [110/20] via 192.168.0.17, 00:02:02, Serial0/0

R6#show ip route | i 10.0.200.0
D EX    10.0.200.0/24 [170/1757696] via 172.16.0.6, 00:05:39, FastEthernet0/1
R6#traceroute 10.0.200.0

Type escape sequence to abort.
Tracing the route to 10.0.200.0

  1 172.16.0.6 36 msec 64 msec 8 msec
  2 192.168.0.17 12 msec 24 msec 12 msec
  3 192.168.0.14 12 msec 40 msec 12 msec
  4 172.16.0.1 16 msec 16 msec 20 msec
  5 172.16.0.6 40 msec 20 msec 44 msec
  6 192.168.0.17 44 msec 24 msec 40 msec
  7 192.168.0.14 44 msec 20 msec 52 msec
  8 172.16.0.1 28 msec 36 msec 24 msec
  9 172.16.0.6 84 msec 44 msec 48 msec
 10 192.168.0.17 48 msec 32 msec 52 msec
 11 192.168.0.14 96 msec 52 msec 32 msec
 12 172.16.0.1 68 msec 44 msec 72 msec
 13 172.16.0.6 60 msec 72 msec 60 msec
 14 192.168.0.17 76 msec 68 msec 108 msec
 15 192.168.0.14 64 msec 80 msec 64 msec
 16 172.16.0.1 76 msec 64 msec 60 msec
 17 172.16.0.6 88 msec 96 msec 92 msec
 18 192.168.0.17 96 msec 104 msec 108 msec
 19 192.168.0.14 88 msec 92 msec 140 msec
 20 172.16.0.1 96 msec 72 msec 88 msec
 21 172.16.0.6 132 msec 136 msec 88 msec
 22 192.168.0.17 140 msec 116 msec 88 msec
 23 192.168.0.14 108 msec 124 msec 120 msec
 24 172.16.0.1 96 msec 104 msec 120 msec
 25 172.16.0.6 140 msec 132 msec 168 msec
 26 192.168.0.17 128 msec 140 msec 156 msec
 27 192.168.0.14 124 msec 120 msec 132 msec
 28 172.16.0.1 168 msec 124 msec 112 msec
 29 172.16.0.6 156 msec 156 msec 152 msec
 30 192.168.0.17 140 msec 168 msec 156 msec

The solution would be to set a tag on the redistributed routes from EIGRP to OSPF (on R4) and filter routes that enter back into EIGRP based on that tag (on R5).

R4(config)#route-map settag55 permit 10
R4(config-route-map)#set tag 55
R4(config-route-map)#exit
R4(config)#router ospf 1
R4(config-router)#redistribute eigrp 1 subnets route-map settag55

R5(config)#route-map stoptag55 deny 10
R5(config-route-map)#match tag 55
R5(config-route-map)#route-map stoptag55 permit 20
R5(config)#router eigrp 1
R5(config-router)#redistribute ospf 1 metric 1500 100 255 1 1500 route-map stoptag55

Now, not having any routing loop back into the EIGRP domain, R6 points to a correct next hop for the RIP destination:

R6#show ip route | i 10.0.200.0                        
D EX    10.0.200.0/24 [170/2244096] via 172.16.0.10, 00:03:04, Serial0/1

R6#traceroute 10.0.200.0

Type escape sequence to abort.
Tracing the route to 10.0.200.0

  1 172.16.0.10 36 msec 4 msec 0 msec
  2  *  *  *
  ...

Note: A route-map clause with no match commands matches all routes, so all routes are assigned tag 55.
Note: After filtering EIGRP-OSPF-EIGRP routes, for a complete solution, the reverse case (OSPF-EIGRP-OSPF) would also need to be configured, using a different route tag value.

No comments:

Post a Comment